Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Das Wettringer Modellbauforum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Sonntag, 23. Februar 2020, 20:11

Probleme beim Programmieren eines Arduinos

Moin Moin,

Ich bin hier neu um mir Hilfe zu holen. Jetzt erstmal zur mir ich bin Kilian, bin 16 Jahre alt und komme aus Niedersachsen. Ich habe mich dem Bereich der Playmobil umbauten zugeordnet. Nun komme ich zu meinem Problem und zwar bin ich dabei meinen ELW (Einsatzleitwagen) der Feuerwehr mit Blaulicht auszustatten. Hier zu benutze ich Arduino Nano um das ganze Blaulicht zur programmieren. Nach dem ich das Script geschrieben habe, habe ich das den Arduino verkabelt zum testen ob alles Funktioniert. Dabei hat sich heraus gestellt das ich wohl nen Fehler gemacht habe und hier liegt folgendes Problem vor: Ich benutze 4 Outputs bei den 2 zusammen gehören und die anderen jeweils einzeln sind und anstatt das die gleichzeitig blinken so wie ich es wollte blinkt alles nacheinander und das war so nicht geplant. Nun wollte ich hier mal Fragen ob jemand das unten angehängte script sich mal angucken könnte ?Okay weil ich die Datei nicht hochladen kann habe ich das hier noch mal für euch hochgeladen (https://workupload.com/file/abLrAkW7 ). Wenn jemand nen Fehler findet könnte derjenige das dann korrigieren und mir zukommen lassen ? Es würde auch reichen mir den Fehler zu beschreiben und vielleicht Verbesserungsvorschläge dazu schreibt. Ich bedanke mich schon mal im Voraus.

Grüße Kilian



( Falls es dazu schon einen Beitrag gibt, tut mir das leid den habe ich nicht gefunden )

2

Mittwoch, 18. März 2020, 13:32

Dein Sketch sagt LED13 an, Pause, LED13 aus, Pause, LED 12 an, Pause, LED12 aus, Pause...klar, dass das nacheinander abläuft. Mal nur von den beiden Outputs 12 und 13 müsste es so aussehen:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
void loop() {
  // put your main code here, to run repeatedly:

digitalWrite(13, HIGH);
digitalWrite(12, HIGH);
delay(75);
digitalWrite(13, LOW);
digitalWrite(12, LOW);
delay(75);

}


Also LED12 und LED13 an, Pause, LED12 und LED13 aus, Pause...
Gruß, Olaf

Bau eingestellt Zerstörer Mölders 1:100 scratch
Abgewrackt Zerstörer Z-17 1:350
Fertig: Hachette U96 1:48, Academy Graf Spee 1:350, VIIc 1:350

Werbung